Microsoft Outlook does not open though Send Mode is set to 0 (default) or displays message "outlook not found"

Issue description

Outlook is used as the default email client, but when trying to email from within SAP Business One with coresuite designer, Outlook does not open. The message "outlook not found" might be displayed.


Search terms

Outlook, email, SAP Prompt, Send Mode, Default, Vista, Windows 7, Windows 2008 Server, PIA

Troubleshooting steps/tips

  1. ensure that the Send Mode in the used Print Definition is set to 0 (Default)
  2. ensure Primary Interop Assemblies (PIA) is installed


Solution

If both the above requirements are met and you are using any of the newer OS with UAC (e.g. Windows 7) you can try to run

  • SAP Business One AND Outlook explicitly as Administrator (activate "Run this program as an administrator" in both applications)
  • or NONE of both as Administrator (recommended)

 

Only for Outlook 2003 and 2007

  1. add and install the attached  SWA_LD_Outlook2007Support.sip manually via the coresuite administration
  2. restart the coresuite AddOn.
  3. set "coresuite designer outlook 2007 support" module active via coresuite administration->Global module configuration

(Warnung) SWA_LD_Outlook2007Support.sip works with/on both Framework version 3.xx and 4.00

Remarks

Primary Interop Assemblies (PIA) can be downloaded for free from e.g.http://www.microsoft.com/download/en/details.aspx?id=3508

Microsoft supplies several primary interop assemblies (PIAs) that contain the official description of the most commonly used Microsoft Office XP type libraries. These Microsoft Office XP PIAs make interoperability easier between managed code and Office XP COM type libraries.

Was this article helpful?
2 out of 3 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.