Skip to main content

GetDesc übersetzt nicht

Comments

7 comments

  • Official comment
    Simon Kaufmann

    Hallo zusammen

    Danke für eure Geduld, es gibt bei uns eine Entwicklungsanfrage #949 bezüglich genau des von euch gemeldeten Verhaltens.

    Ich würde euch bitten ein Ticket (Mail an support@coresystems.ch) und mich ins Cc zu packen, dann werdet ihr über unser Ticketing System von der Entwicklung über die weiteren Schritte informiert.

     

    Gruss

    Simon

  • Lothar Hasenkämper

    Hallo Rene , @Coresytems,

    ich habe das gleiche Problem.

    Gruß Lothar

    0
  • Simon Kaufmann

    Hallo zusammen

    Soweit ich weiss könnt ihr dafür die GetMLDesc - Funktion benutzen: http://helpfiles.coresystems.ch/help/country_package/manual/de/getmldesc.htm?zoom_highlightsub=GetMLDesc

    Diese gibt die "Multilanguage Description" züruck, deshalb MLDesc.

    Hoffe das hilft. Gruss

    Simon

    0
  • Lothar Hasenkämper

    Hallo Simon,

    in der Anleitung steht, dass es auch mit "GetDesc" geht. Es muss nur der LangCode als Parameter mitgegeben werden.

    Gruß

    Lothar

    (SAP Business One 10.0 (10.00.160) FP 2105 (64-bit) / Designer 7.45.08201)

    0
  • Lothar Hasenkämper

    Hallo Simon,

    GetMLDesc funktioniert auch nicht.

    Eigentlich ist GetDesc ja genau dafür gedacht, wenn das UDF ValidValues hat.

    Gruß Lothar

    1
  • René Jakobs

    Hallo Lothar, hallo Simon,

    vielen Dank für Eure Rückmeldungen. Ich habe mich diesbezüglich auch durch alte Foreneinträge hier gelesen und auch dort wird immer gesagt, dafür solle man GetDesc nutzen. Wie Lothar erwähnte, empfiehlt auch das Handbuch für den Fall mit ValidValues extra diese Funktion.

    Man kann nun natürlich über verschachtelte dynamische SQL-Abfragen die Funktion nachbauen, aber ich dachte, dass ich vielleicht einfach den Wald vor lauter Bäumen nicht sehe – scheint jedoch nicht so zu sein, wenn selbst Lothar als SAP-Experte (man kennt sich ;)) dasselbe Problem hat.

    Die Specs bei mir entsprechen denen von Lothar:
    Coresuite Designer 7.45.08201; SAP Business One 10.0 (10.00.160) FP 2105 (64 bit)

    Laut einer Mitarbeiterin trat das Problem vor ~ 2-3 Jahren nicht auf und wäre angeblich richtig übersetzt worden. Da ich seit 3,5 Jahren den Coresuite Designer in der Hand habe und dort nie etwas angepasst habe, ist es vielleicht ein "neues" Problem? Aber es muss bereits einige Versionen bestehen, denn wir haben das Problem seit etwa mindestens einem Jahr; da waren wir auch noch auf SAP 9.3.

    Grüße René

    0
  • Lothar Hasenkämper

    Hallo Simon,

    leider haben wir von dir nichts mehr gehört.
    Konntest du das Problem reproduzieren.

    Gruß Lothat

    0

Please sign in to leave a comment.