Update auf Country Package 4.1

Thomas Faust

Hallo Zusammen,


ich habe mich bemüht über die Suchfunktion eine Lösung zu finden, bin aber gescheitert.


 


Nach dem Update auf die aktuelle Version 4.1 habe ich folgendes Problem:


 


Beim Start von Coresuite Customize erscheint folgender Fehler:


"coresuite customize - Kompilierfehler. Übeprüfen Sie ihren Code ..."


 


Die nun erscheinendeFehlermeldung ist für mich etwas unverständlich und ich schaffe es nicht eine Lösung zu finden:



Der Interoptyp, der mit dem eingebetteten Interoptyp "SAPbobsCOM.BoObjectTypes" übereinstimmt wurde nichtgefunden. Möglicherweise fehlt ein Asemblyverweis. (CS1748)

Der Verweis zielt auf folgende Code-Zeilen:



SAPbobsCOM.Company oCompany = SwissAddonFramework.B1Connector.GetB1Connector().Company;
SAPbobsCOM.Recordset oRSCodeMax = (SAPbobsCOM.Recordset) oCompany.GetBusinessObject(SAPbobsCOM.BoObjectTypes.BoRecordset);

Vor dem Update funktionierte alles tadellos!


 


Für sachdienliche Hinweise bin ich sehr dankbar!


 


Bislang habe ich schon, entsprechend der Anweisung, Corsuite komplett deregistriert, deinstalliert und die "COR"-Verzeichnisse gelöscht, das TEMP-Verzeichnis geleert und anschliessend alles wieder installiert. Leider ohne Erfolg.


 


Viele Grüße


Thomas



Paolo Manfrin

Hi Thomas,


this error seems to point to a problem with the SAP dlls.


 


Try to reinstall the SAP dlls from the download area.


 


If you still have the issue please could you log a ticket at helpdesk.coresystems.ch


 


Cheers


paolo



Thomas Faust

Hallo Paolo,


thank you for your help, but unfortunately the error ist still there.


 


I have download th Corsesuitelogfileanalyzer and the logfile says that the Type "SAPbobsCOM.BoObjectTypes" ist defined in SAPbobsCOM.DLL and in COR_COAC.dll (CS0433)


 


Later i will log the ticket at Helpdesk.


 


thanks


Thomas



Sonja Altschuh

Hello,


 


thanks for forwarding your request via your partner to our help desk. We need to make sure that 


1.  you use customize  4.11 => you already do...


2.  remove sips from the coresuite db, that are not compiled to work with .NET 4.0 (e.g cost accounting)


I will schedule remote meeting via your partner.


 


Kind regards,


Sonja



0

Comments

0 comments

Please sign in to leave a comment.

Didn't find what you were looking for?

New post