Side By Side in advancegroupband

James Clark

Hi
I am trying to create a product catalogue, attached is a print screen of the design layout and the output I have so far,
I have having problems with aligning the sidebyside element, as you can see on the image (see attached) line number two is on a different line from one and three.
I have the following code on the render.visible element on each detail in the sidebyside advancedGroupBand3.LineNumber MOD 3 = 1 changing the to MOD 3 = 2 on detail3 and MOD 3 = 0 on detail4. I have made the same layout without the group elements and this code works fine. Can anyone help me here get the sidebyside lining up??
:bang: :bang: :bang:

Attachment
[url=http://www.coresystems.ch/wp-content/../wp-content/forum-image-uploads/james-clark/Layout Design & Output.JPG]Layout Design & Output.JPG[/url]

Philipp Knecht

Hi James

Hmm i think your structure is wrong.

you should only use databands which contains groupbands. Groupbands which contain databands will not work in every case...

Make sure that the advanceddatabands are within the SideBySide.

If this doesn't help please send the support package (lookup in FAQ) to us.

hth

James Clark

Hi Philipp



i have tryed to remove the Advancedatabands in the sidebyside element (see results in attached file)

As you should see all detail lines line up but i now have three of one item.

Any Ideas???

Attachment
[url=http://www.coresystems.ch/wp-content/../wp-content/forum-image-uploads/james-clark/Layout & Design Without ADB.JPG]Layout & Design Without ADB.JPG[/url]

Philipp Knecht

Hi James

SideBy Side in Groupbands will conceptually not work.
But if you put the sizes of your 2nd and 3rd Detail to 0 it'll also work.
I've send you the extract from your SupportPackage.

hth

James Clark

Hi Philip

It seems that if i set details 2 & 3 to size 0, it comes out the the following output (see attached) line 2 and 3 have now lined up but seems to be a formet issue for line one :bang: :bang:

i have sent a support package last thursday.

Meny thanks philip for your help

Attachment
[url=http://www.coresystems.ch/wp-content/../wp-content/forum-image-uploads/james-clark/Layout Design & Output (with 2&3 set to zero).JPG]Layout Design & Output (with 2&3 set to zero).JPG[/url]

Philipp Knecht

Hi james

You are pretty close tothe solution.
Just put the contents of detail 2,3 to the area above the detail itself.

hth

James Clark

Hi Philipp

I have tried everything to get the detail bands to line up but they just wont either the first detail is correct but details 2 and 3 skip the first row then go past the end of the page (please see previous attached image "Layout Design & Output (with 2&3 set to zero).JPG" )

i am sure i am missing something. can you help??

Philipp Knecht

Hi james

We can solve that via remote session if you like.
In this case we need to invoice you then.

hth

James Clark

Hi Philipp

This is fine, what will i need to do send you a PO first??

regards
James

Philipp Knecht

Hi james

Contact our support desk.
They can schedule a meeting for an remote session for me.

hth
0

Comments

0 comments

Please sign in to leave a comment.

Didn't find what you were looking for?

New post