UDF verlieren Werte

Thomas Faust

Hallo Zusammen,

Ich habe ein kurioses Problem mit einigen Optimizer -Regeln.

Wir haben mittels Customize einen Folder erzeugt und einige UDF's darauf platziert.

Die Felder werden komplett in der Customize - Rule erzeugt und mittels Databinding and die UDF gebunden.

Bei Double Werten wie zum Beispiel Preisen passiert jetzt folgendes:

Wenn ich in einem Kundenauftrag einen Preis in ein UDF auf der Main Form eingebe und die DB aktualisiere, dann werden die Werte übernommen und in der DB gespeichert.

Erzeuge ich jetzt aus diesem Auftrag zum Beispiel eine Lieferung, dann steht in diesem Feld kein Wert!

Wenn ich die entsprechende Regel ausschalte und die Werte direkt auf der UDF-Form eintrage, dann funktioniert alles.

Augenscheinlich ist meine Regel korrekt, denn die Speicherung in der DB funktioniert in jedem Beleg für sich, nur die Übernahme in den nächsten Beleg funktioniert nicht. Mache ich einen Fehler oder ist es ein Fehler?????


Viele Grüße und schöne Ostern

Thomas

Thomas Faust

Hallo Zusammen,


das Problem entspringt einfach einem Gedankenfehler meinerseits :unsure: !

Bei Übernahme der Daten in einen neuen/Nachfolgebeleg werden die Daten vom SAP nur in die Form geschrieben, wenn ich dann mit DataBinding ein DB-Feld zuweise, dann sind die Felder leer, was auch richtig ist, denn in der DB existiert dieser Belg, und damit auch die Werte noch nicht.


 


Gruß


Thomas


0

Comments

0 comments

Please sign in to leave a comment.

Didn't find what you were looking for?

New post