Getting Started with Cloud Reporting

Source: This article refers to Getting Started with Cloud Reporting

In a Nutshell

This guide will show you how to create a report with data on one of your business partners.


First Things First

Install Jaspersoft Studio

Jaspersoft Studio is a free, open source, Eclipse-based report designer. You can download it from here. Make sure that you have one of the newer versions.

Note: When signing up for a free account, is recommended to select the “No, thanks” link contained in the account registration dialog. The download will then commence.

Install Report Designer

Report Designer is a plugin for Jaspersoft Studio which allows you to design reports for Coresystems solution.

The installation process is exactly the same as for any other Eclipse or Jaspersoft Studio plugin:

  • Start Jaspersoft Studio, then select Help > Install New Software.
  • Click Add... in the top-right corner.
  • In the Add Repository dialog that appears, enter Report Designer for the Name and the following URL for the Location:
http://reportdesigner.coresuite.com/updates/
  • Click OK.
  • In the Available Software dialog, select the checkbox next to Coresystems Report Designer and click Next.
  • In the next window, you’ll see a list of the tools to be downloaded. Click Next.
  • Read and accept the license agreements, then click Finish. If you get a security warning saying that the authenticity or validity of the software can’t be established, click OK.
  • When the installation completes, restart Eclipse.




Next Steps

Create a New Data Adapter

Data Adapter defines the data source. The Query API or can be used to return relevant company data.

  • Create a new data adapter of type Coresystems Cloud Connection. You are free to use any name you like.
  • Enter your Coresystems account credentials and click Login. Choose your company. You can also select the demo account.
  • Click Test to make sure that your connection is working.



Create a New Project

A Jasper project is a container for your report. It includes designs, style files, translations and images.



Create a New Report

A Jasper report is a design. Create a new one inside your project, using the blank template.



The main report must be named report.jrxml as this is the starting point. You can create zero or more subreports.



Define the Data Query

Now it’s time to define what data to include in your report:

  • Open the Dataset and Query Dialog dialog (the icon in the top right corner of the Design view).
  • Select your data adapter and CoreSQL as the query language.
  • Enter the following query in the query panel:
BusinessPartner ? query = id = $P{businessPartner.id} & dtos = BusinessPartner.12

This query will return a business partner with the some id. The dtos parameter specifies the version of the transfer object. For more details please refer to the Query API documentation.



Create Fields

Report field represents a way to map data from data source into the report. You can define a field yourself, or click the Read Fields button to retrieve possible fields. You can find all possible fields and suitable data types for every object type in the Query API documentation.

Add a new field businessPartner.name of the type java.lang.String. You can add more fields if you like. Once you’re done, go to the Design window, drag and drop the field from Outline view to Detail band. For every business partner, in our case just one, a detail band instance will be inserted into your report.

Create Parameters

Report parameter represents some data which is used in the report, but is not present in the data source.

Add a new parameter businessPartner.id of type java.lang.String. Add a custom property on it with the name autoSet with the value objectId. This will allow the client applications to generate input fields so the user can select a business partner for the report.



If no parameters exist for the report, the report will be available as a “Menu Report”. Otherwise, the report will be stored on the data object (example: Business Partner, Activity, etc.).

Upload Report Template

Make sure that the project is compiling without any errors. You need to upload the project to your Coresystems Cloud account. To do so, you can use the Upload feature:

  • Select the project you want to upload.
  • Select the company database to which you would like to upload the report.
  • Select Project > Upload the Report to Coresystems Cloud from Eclipse menu.
  • Select the connection you want to use.
  • Select the project you want to upload.
  • Choose the name under which your report will be visible. Keep in mind that the name has to be unique.
  • Click Finish.



Download Report Template

You can also download report templates from your Coresystems Cloud account. To do so, you can use the Download feature:



  • Select the project you want to upload.
  • Select Project > Download the Report from Coresystems Cloud from Eclipse menu.
  • Select the connection you want to use.
  • Select the project you want to download.
  • Click Finish.

Build the Report

You can build your report by going to the Analytics & Reporting app and signing in with your coresystems account credentials.

After selecting the report you created from the Templates dropdown menu, select the generate button to display the report.



Note: Preview reports can be downloaded in excel, word, and PDF format.

Where to Next?

You can find more information on Coresystems Reporting in the User Guide.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.