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Changelog 
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1.4 2018/08/31 Bernhard Weiersmüller Added Parameter to SQL Query 
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1 Prerequisites 

- SAP FSM Cloud Account 

- Basic understanding of SQL  
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2 Installation and configuration of JasperSoft Studio 

2.1 Goal 

In this section you will learn 

• How to download and install JasperSoft Studio 

• How to add a Data Adapter 

• How to create a new project 

• How to add a new empty Jasper report 

A Data Adapter is a connection to a cloud database. You can have multiple data adapters. 

A project contains all your configurations and settings regarding your reports. You can have multiple reports 

inside one project. 

 

2.2 Step by Step 

 Scenario Steps 

1 Download 

and in-

stall Jas-

perSoft 

Studio 

1. Download JasperSoft Studio from here: https://sourceforge.net/projects/jasperstudio/ 
2. Install JasperSoft on your PC 
3. Startup Jaspersoft Studio, then select “Help > Install New Software” 

 
1. Click Add... 
2. Add “Report Designer” in the “Name” field 
3. Add https://reportdesigner.coresuite.com/updates/ in the “Location” field 
4. Click “Add” then Read and accept the license agreements, then click Finish. If you get a 

security warning saying that the authenticity or validity of the software can’t be established, 
click OK. Restart JasperSoft. 

https://sourceforge.net/projects/jasperstudio/
https://reportdesigner.coresuite.com/updates/
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2 Add the 

SAP 

Cloud 

Connec-

tion Data 

Adapter 

 

1. Click on Repository 
2. Right click on Data Adapter and choose “Create Data Adapter” 
3. Choose “SAP FSM Connection” to be able to connect with your FSM Cloud User 
4. Click “Next". This will open a new dialogue where you have to enter your login infor-

mation. 
 

 

1. Enter a name for your Data Adapter.  
2. Enter your FSM Cloud Account Name here 
3. Enter your FSM Cloud User Name here 
4. Enter your FSM Cloud User Password here 
5. Click Login. If successful it will show “Company list retrieved” 
6. Here you can select the Company you want to connect with 
7. Click “Test” to test the connection 
8. Click “Finish” 
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3 Create a 

new pro-

ject and 

an empty 

new re-

port 

 

1. Select “Build Automatically” under the “Project” menu.  
 

 

 

1. Click “File>New Project” 
2. Choose “JasperReports Project” 
3. Click Next 
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1. Choose “File>New JasperReport” 
2. Choose “SAP FSM Reports” 
3. Choose the blank FSM Report. This is a predefined template and contains already most 

things you will need. 
4. Click Next 
 

 

1. Select your newly created project 
2. Do NOT change the File name (report.jrxml) as this will be used by the standard report 

template. This will be your main report which can then include subreports if needed. 
3. Click Next 
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1. Choose your Data Adapter to connect to the corresponding database 
2. Choose Next to finish your report 

 

   

 

3 Edit and preview your Report Data 

3.1 Goal 

In this section you will learn: 

• How to edit the Report title 

• How to preview the compiled report 

• How to check compilation errors 

 

Your report will be viewable in different places: 

In the mobile FSM app and in FSM under “Analytics & Reporting” 

 

A preview of your report will show you how the report will look like. 

3.2 Step by Step 

 Sce-

nario 

Steps 
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1 Open 

your new 

empty 

report  

 

1. Click on the Tab called “Project Explorer”. This will then show all your projects. Projects are col-
lections of your work and reports. 

2. Open your project and double click on report.jrxml to open the main report. 
3. Your report then opens up in the middle section of the screen. There you will edit your report de-

tails from now. 
 

2 Edit the 

title of 

your re-

port 

 

1. Double click on the “Title” Textfield in your report 
2. This will open the “Expression Editor”. This editor will be used for editing your report fields. Here 

you will be able to use expressions, calculations and resources. 
3. Change the text called “Title” to “Activity: “. Click Finish 
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3 Create a 

dataset 

with 

CoreSQ

L lan-

guage 

 
1. Click on the Symbol to open the “Dataset and Query Dialog” 
2. To be able to preview your empty report, you need to add a dataset. This is the data you select 

from the database using a SQL similar query. Make sure you have selected the correct data 
adapater.  

3. Choose “CoreSQL” as your query language. 
4. Enter a first query into the box: SELECT ac from Activity ac. This will select all data from the 

table called “Activity”. The syntax is SQL like with some differences. For example you will always 
need to specify table name aliases. Also the Asterisk (*) is not supported. This query will select 
all rows from the table Activity. Table names and Fields are case sensitive! Find the syntax in the 
SAP Help Portal (Search for Query API). 

5. Click on “Read Fields”. This will query the database with your query. 
6. Here you can see all tables of your database 
7. This shows the versions of your tables. If SAP releases a new version of a table, then the version 

number is increased. 
8. Click “Refresh Preview Data” to show the data 
9. Data preview shows all the columns returned by your query.  

 
As this is not ideal for preview it is advised that you always create and test your query in 
the Admin part of FSM first as described in the following steps.  
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1. Login to FSM/Administration and then click on Companies 
2. Select your company 

 

 

1. Click on Query API 
2. Enter your query in the CoreSQL syntax 
3. Execute the query by clicking on Execute or pressing F5 on the keyboard 
4. See the resulting dataset here in the table. 

4 Create 

Activity 

Report 

with no 

filtering 

 
1. Add a text field to the report by dragging an empty one from the “Basic Elements” section to the 

Detail Band of your report. Edit the content and add “Activity Code: “ + $F{ac.code} 

2. Add another text field with “Activity Subject: “ + $F{ac.subject} 

3. Add another text field with “Activity Status: “ + $F{ac.status} 
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1. To preview your report click on Preview tab 

2. Use the controls above the report to wander trough your report pages. Without filtering this report will show 

many pages with many activities. 

3. Details of Activity with Code 5 are shown here 

4. Details of Activity with Code 14 are shown in the next paragraph 
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3.3 How to check for compilation errors 

 

 

1. Click on “Preview” to compile your report.  

2. Double click on the error message. This will open the Expression Editor of the element which caused this 

error message 

3. In this example the element (the Title of the report) does not have speech marks which produced the error 

4. If you use the Compile dialogue, when double clicking on the error message, nothing will happen! So make 

sure to always use the “Preview” Tab instead! 
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4 Add parameters, calculations and a subreport 

4.1 Goal 

In this section you will learn: 

• How to use Parameters in your report 

• How to add a subreport to your main report 

• How to use variables 

• How to create calculated fields 

• How to use functions (like concatenate) 

 

Subreports are reports inside the main report. They are used to group data in your report. 

Parameters are used to only select the dataset you need.  

They can be used in two different ways: 

- Use a parameter to view a report for a certain value for testing purposes (instead of viewing everything). This 

is done by putting in a value each time you run your report or by putting in a default value. These parameters 

are referenced by $P{parametername} in your query. They are specified in the “Parameters” Section of your 

report. Also when the report is running on the mobile or online this parameter is used to handover a key 

value for the report generation (i.e. the activity code). 

- Use a subreport parameter to handover a certain value to your subreport. The subreport will then use this 

value in its query to narrow down the data to be displayed there. A subreport parameter is configured when 

you go to the subreport properties and click “Edit Parameters”. 

Variables are used to display calculated values. They can be referenced by $V{variablename}. 

Fields are used in queries and contain a certain value from a table. They can be referenced in a report by 

$F{tablealias.tablefield}. 
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4.2 Step by Step 

 Sce-

nario 

Steps 

 

1 Add 

a pa-

ram-

eter 

to 

your 

main 

re-

port 

 

1. Edit your query to have a parameter in it: 
“select ac from Activity ac where ac.code = $P{Activity Code}” 
Make sure, that you have selected your main report in your project. 

2. Right click on Parameters in the Outline tab and click “Create parameter” 
3. A new parameter will be created. 
4. On the right hand side of JasperSoft Studio you can edit your new parameter. Name it “Activity 

Code”.  
5. Choose Type “Text” 
6. Click on the tab Object.  

 

 

1. Here you can edit the parameter name. We set it to Activity Code in this example. 
2. This is the Parameter class. For certain things like Date calculations it is useful to choose the correct 

Class type. 
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3. Here we can add a default value. This is useful for testing purposes. Everytime you compile your 
report it would use this default value for the parameter. When you preview your report you would 
have to enter a value every time manually if you leave this Default Value Expression empty (see be-
low screenshot). Make sure that you set the value in double quotes. 

 
 

 

1. Click on the Preview tab 

2. You will see the default value already entered for the Activity Code.  

3. Press the green arrow to view your report 
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1. Your report should look similar to the one shown here. Only one activity is shown because we fil-

tered the data using the parameter Activity Code. 

2. Only one page can be seen now because of the parameter! 

 

2 Cre-

ate a 

Sub-

repor

t 

For the next steps please create a new project. Then create a new main report in the new project. 

 

 

1. Select your new main report 

2. Right click on “Parameters” and choose “Create Parameter” 
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3. Click on your new parameter 

4. Edit the name of the new parameter and call it “objectID” 

5. Choose the Type to be “ObjectId” 

6. Click on the “Object” tab which will show the next screen 

 

1. Here you can edit the parameter name.  

2. This is the parameter class. For certain things like date calculations it is useful to choose the 

corresponding class. 

3. Here we might add a default value (in double quotes!) for the objectID. This is useful for testing your 

report. When you first preview your report you will have to enter a value before you can proceed if 

you leave the default value empty. Do not forget to REMOVE the default value when you are 

finished with your report. Otherwise your report will not work correctly in the mobile app or in the 

cloud and always show the same data. 

How do you know what value to enter as the objectID? See next screenshots for an in depth 

explanation! 

 

1. Open the Query API in FSM>Administration>Company>Query API and enter the following query: 

SELECT a.id, a.code, sc.subject,sc.businessPartner,bp.id,bp.name FROM Activity a  

INNER JOIN ServiceCall sc ON a.object = sc.id 
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INNER JOIN BusinessPartner bp ON sc.businessPartner = bp.id 

ORDER BY bp.name 

2. Execute the query and look at the results 

3. This is the BusinessPartner ID in the BusinessPartner table 

4. This is the BusinessPartner ID in the ServiceCall table. You can see how these IDs are linked 

between both tables 

5. Choose an activity ID value from the list and save it for later when you need to provide an activityID 

to preview your report. This value is then needed to link to the query in the subreport. You can read 

here to see where you need to provide this value. 

 

1. Click on Subreport element 
2. Drag the Subreport element to your new main report and drop it into the details pane 
3. Choose “Create new report” 
4. Click “Next” 
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1. Choose “Coresystems Reports” (SAP FSM Reports)  
2. Choose the template 
3. Click Next 

 

1. Choose your project 
2. Click Next 
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1. Choose your Data Adapter 
2. Click Next. 
 
 

 
1. In this field you could enter a query. For this example we leave this blank and enter the query later 

on. 

2. It is Ok to click OK now 😊 
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1. Click Finish 
 
 

 
1. In the main report you can now see the subreport as a red rectangle. This means it is not fitting in 

the main report. You have to resize it. 

 

1. Select your subreport 
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2. Change the size of the subreport to w = 555 and h = 60 px. Now double click on your subreport and 

it will open a new window where you can edit the subreport. 

 

1. In your subreport open the query editor. Here you can edit your dataset. 

 

1. Choose your Data Adapter 

2. Choose Language “CoreSQL” 

3. Enter this query into the editor: 

SELECT te FROM TimeEffort te WHERE te.object = $P{activityID} 

This will select all data from TimeEffort table using the given activityID Parameter. This parameter is 

configured in the main report (see below) and will contain a value handed over from the main report. 

4. Click OK to save the query 
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1. Go back to your main report and open the Query Editor. Make sure CoreSQL is selected as 

Language 

2. Delete the existing query and add the following new query in the editor: 

SELECT a,sc,bp,ad FROM Activity a INNER JOIN ServiceCall sc ON a.object = sc.id INNER 

JOIN BusinessPartner bp on sc.businessPartner = bp.id LEFT JOIN Address ad ON ad.object 

= bp.id WHERE a.id=$P{objectID} 
 

This query will select information based upon a parameter value (objectID). This value will later on 

be provided from the mobile app when you want to see a report for a given activity. 

 

 

1. To add a Parameter which can then be used in the subreport, you have to go to the main report. 

Select the subreport by clicking on it. 

2. You will see the subreport Properties on the right. Select the tab “Subreport” to be able to edit the 

Parameter. 

3. Click on “Edit Parameters” 

4. Here you click “Add” to add a new parameter 

5. Choose a name for your parameter. This name will be referenced in this example in the subreport 

(see above) as $P{activityID} and should be used to define the dataset for the subreport.  
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6. Here you define the value of your parameter. This is a field value which contains the Activity ID 

(from your query). 

7. Click OK 

8. Click Finish 

 

1. Open your subreport and delete everything except the Detail band. Add a Column Header by 

right clicking on it and then choose “Add Band” from the menu. 

2. Your new Column Header Band is added here 

3. Add a Column Footer 

4. Your new Column Footer Band is added here. Then your subreport should look like in the picture 

above. 

 

1. Click in the gray area in the middle of your screen. This will select the Subreport Properties which 

can then be changed on the right hand side. There click on “Edit Page Format” to change the size of 

the subreport. 

2. In the upcoming “Page Format” change the Width to 555. 

3. Change the Height to 60 

4. Change top margin to be 0 
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5. Change bottom margin to be 0 

6. Change left margin to be 0 

7. Change right margin to be 0 

8. Click OK. 

 

1. Select the Column Header. 

2. Change the Height to 20 

3. Change the Detail Height to 20 

4. Change the Footer Height to 20.  

 

1. IF you cannot change the Height sizes (can be buggy) you have the possibility to change the sizes 

directly in the source. Click on Source. 

2. Edit the Height of the ColumnHeader Band to 20 

3. Edit the Height of the Detail Band to 20 

4. Edit the Height of the ColumnFooter Band to 20. Then click on Design and the Subreport should 

now show the correct size. 
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1. To add a new Variable you right click on Variables and choose “Create Variable”. Variables are 

used to calculate values. We want to have the duration of an activity calculated as this value 

cannot be found in the table. 

2. Name your variable 

3. Choose java.math.BigDecimal for calculation 

4. Calculation does not need to be changed for this type 

5. Click on the Expression Editor Icon. This will open the Expression Editor where you can then add 

a formula for your variable 

6. Add the following formula: 

(new BigDecimal((DATEVALUE( $F{te.endDateTime})-

DATEVALUE($F{te.startDateTime}))/(1000.0*3600))) 

This will use the Fields from your query and calculate the duration.  

7. Click on Finish. If you have a syntax error it will show you an error message. 

 

1. Now we want to create a calculation on a field. Here we want to have a sum of the durations of a 

certain activity. To do this we create another Variable called “Total Duration”.  

2. Call the Variable “Total Duration” 

3. Choose the Type as “java.math.BigDecimal” 

4. Now we can use the builtin Calculation method where we choose “Sum” 

5. For the Expression we choose the variable we defined in the above steps: $V{Duration}. So the sum 

will be calculated over all the Durations of a certain activity. 



Workbook 

 www.coresystems.net Seite 27 von 32 

 

1. Finally we put the relevant field onto the subreport. First drag and drop a text field from the right and 

enter “Start Datum” as the value. Put it into the Column Header Band. 

2. Add another text field but this time put it into the Detail Band. Add the value there as a Field Value 

($F{te.startDateTime}).  

3. Add text field with “Startzeit” as a value into the Column Header Band 

4. Add text field with the same variable as before.  

5. This is the Variable definition 

6. Here you can format the variable so it will only show the time but not the date. Click on the dotted 

button. This opens the pattern editor. 

7. In the pattern editor choose Date and then select the pattern which is the closest to what you need.  

8. Here you can finetune the pattern and delete the date placeholders so the pattern remains as 

“h:mm a”. 

9. Click Finish 

10. Add text field with “Endzeit” as a value into the Column Header Band 

11. Add text field with a field $F{te.endDateTime} 

12. Add text field “Dauer” 

13. Add text field with variable “$V{Duration}” 

14. Add the calculated field “$V{Total Duration}”. This is the only field which is located in the 

ColumnFooter band. 

 

1. Now finalize your main report. To do this place a text field with “Activity: + $F{sc.subject}” into the 

Page title band. The syntax to concatenate strings is by just using a “+” sign between the two strings 

or field values. 

2. Add a text field with “Businesspartner: “+ $F{bp.name} 
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3. Add a text field with “Strasse: “ + $F{ad.street} 

4. Add a text field with “Activity ID:” + $F{a.code} 

5. Add a text field with "Strassennummer: " + ($F{ad.streetNo} == null ? "Nicht definiert" : 

$F{ad.streetNo} ) 

This is the syntax for a conditional field value. It means, that if the query returns a null value for the 

Street number, then it prints “Nicht definiert”. Otherwise it simply displays the Street number. 

 

1. To now preview your full report you need to click on the Preview tab below your main report 

window.  

2. In the objectID Field it displays your default value you entered for the objectID variable. Here you 

could also choose another value and change it manually before your report gets displayed. This 

value is entered without double quotes. The value was taken from a query in the QueryAPI in FSM 

earlier on (click here to go back there). 

3. Click on the green arrow to display your report. 
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1. Your report should look similiar to this example report now. 

 

 

1. Before you upload your new and shiny report, you need to delete the default value (if set) of the 

variable objectID. To do this click on the parameter in your main report. 

2. In the properties tab on the right side you can then delete any value in the “Default Value 

Expression” field. 

 

1. As a next step you need to click on the “Appearance” tab for your variable objectID 

2. In the “Auto Set Menu” choose “objectId”. This will make sure that when you call the report on your 

mobile app the objectId is transferred automatically so your report is linked to the corresponding 

activity. 

 



Workbook 

 www.coresystems.net Seite 30 von 32 

 

 

1. When you are satisfied with your report you can upload it to your cloud account. Click on 

Project/Upload Report to SAP FSM Cloud. 

 

1. Select your data adapter where you want to upload your report. 

2. Click Next 
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1. Select your project with your report 

2. Choose the Object Type where you want to associate your report with. This means, that the new 

report will show up in the corresponding category on the mobile app. Our report will show up in a 

certain activity. 

 

1. In your mobile app you choose the detail view of a certain activity. By clicking on “Print & Send” or 

“Export” (using the … Menu) you can choose your new report template and view your new report on 

the mobile! 

Congratulations! You now have successfully created a report with JasperSoft Studio! 
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